You need to have Flash Player 9 installed to use the video player application.